Change php version 7 on heart internet

Share on FacebookTweet about this on TwitterShare on Google+Share on TumblrPin on PinterestShare on LinkedInShare on RedditDigg thisShare on StumbleUponEmail this to someone

If you use Heart Internet and want to use php 5.6 or php version 7 on heart internet then you cannot change the PHP version above 5.5 in the Extend Control Panel. However you can change the PHP version to 5.6 or 7.0 using other means.

Both PHP 5.6 and 7.0 are available on the Heart Internet platform and can be accessed via editing the .htaccess file within the package to the following: 

SetEnv DEFAULT_PHP_VERSION 56

SetEnv DEFAULT_PHP_VERSION 70

 

So, to recap, use the first line to change the PHP version to 5.6.3 and the second line to PHP version 7.0.14.

You can edit your .htaccess file by logging into your extend control panel. Visiting File Manager and then go to public_html and you can either add a new .htaccess or edit your existing one.

 

 

You May Also Like

2 thoughts on “Change php version 7 on heart internet

  1. Thanks for this, been wondering about this for a while seeing lots of developers using 7 and feeling a bit left behind. It’s a bit concerning that HI haven’t enabled this on the php version option.

  2. Stumbled across this site when changing all my client sites to PHP 7, and then thought… i know that name…
    Mr Allen has mentioned in the past that you do his IT stuff! Small world!

Leave a Reply

Your email address will not be published. Required fields are marked *

Current day month ye@r *